Following the principle of least surprise, DerSaidin's proposal makes a lot of sense.
The question is do we really want a new keyword such as fallthrough or fallthru? As an alternative to a new keyword, we could use the goto keyword with new semantics:
goto next; /* fall thru to the code below */
goto default; /* to branch to the default case */
goto case 'a'; /* to branch to the handler for 'a' */
Regarding combining multiple cases, it would be preferable to allow multiple case statements to follow one another without any intervening statement as this is the common idiom for C and it is widely used and poses no real problem. We could also extend the syntax for the case clause, but with operators that do not clash with current use: commas could be used to enumerate values, and a range operator could be introduced for to specify inclusive value ranges (.. seems an obvious choice for this).